Exchange your Mind

"La connaissance ne vaut que si elle est partagée" / "An effective Knowledge is a shared one"

Archive for the ‘Owa-2010’ Category

Office365 – AD FS 2.0: Client Access Policy Builder

Posted by David ANDRE le juillet 2, 2012


L’équipe produit ADFS vient de publier un script PowerShell venant compléter les nouvelles fonctionnalités du HotFix Rollup 2 pour ADFS 2.0.

Ce script (qui est en fait un assistant) permet de créer des polices d’accès de manière très granulaire, comme par exemple : bloquer tout accès externe à Office365 excepté l’OWA.


Il est disponible gratuitement sur la galerie TechNet: http://gallery.technet.microsoft.com/scriptcenter/Client-Access-Policy-30be8ae2#content

Have Fun J

Posted in 4-ACTIVE DIRECTORY, Cloud, Office 365, Outils-2010, Owa-2010, Powershell, script | Leave a Comment »

An unexpected error occurred and your request couldn’t be handled. OWA 2010

Posted by Teruin laurent le mai 10, 2012


Error Message : An unexpected error occurred and your request couldn’t be handled / The service ‘/EWS/exchange.asmx’ cannot be activated due to an exception during compilation

We have encountered this issue on 3 fresh Exchange 2010 installations SP1 RU1 on OWA when trying to delete a message on OWA
Nous avons rencontrés dans le cadre d’une installation Exchange 2010 le problème suivant lors de la tentative de suppression d’un message dans OWA



We have decided to install RU2 reboot etc…
Nous avons installé le RU2 . meme probléme

Same issue
Our binding on default website are


When we try to delete a msg on owa we have this on application log.
En supprimant un message nous avons vu dans le journal des applications les entrées suivantes.


WebHost failed to process a request.

Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/56566820

Exception: System.ServiceModel.ServiceActivationException: The service ‘/EWS/exchange.asmx’ cannot be activated due to an exception during compilation. The exception message is: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

Parameter name: item. —> System.ArgumentException: This collection already contains an address with scheme http. There can be at most one address per scheme in this collection.

 

Outlook Web App couldn’t connect Exchange Web Services due to a configuration error. Response code = "500".

We change the binding in a way to have just one binding per port


Same Issue

The certificate on IIS is ok and contains right Subject alternate name

Le certificate sur IIS est correct et contient les bon SAN

We have delete the second entries http 4443 used for a specific remote powershell connection and it works again.

Nous avons supprimer l’entrée que nous avions ajouter et tout refonctionne.

The question is now … how to have a secondary bindings ;-)
La question est désormais de savoir comment l’on peut mettre une seconde entrée sans avoir ce souci .

Cordialement
Laurent Teruin

Noubliez Pas ! Si vous désirez avoir acces au réféntiel documentaire envoyez un message à Unifiedit@hotmail.com !

 

 

 

Posted in 1-EXCHANGE 2010, Owa-2010 | Leave a Comment »

IIS redirection vers OWA Exchange Server 2010

Posted by David PEKMEZ le décembre 4, 2010


Dans cet article je vais vous présenter comment rediriger la racine de votre site web par défaut vers le répertoire OWA de votre serveur.

La méthode est assez simple sous Exchange 2010 comparée à ceux qui s’en souviennent à la méthode Exchange 2003.

Afin d’éviter de tomber sur cette fameuse page d’accueil pas très …. Accueillante…


Tout d’abord, entrez un enregistrement « Friendly » dans votre DNS du type : mail.contoso.com afin de l’utiliser pour vos accès OWA


Ouvrez votre console de Gestion IIS de votre serveur d’Accès client

Double cliquez sur « http Redirect »

  • Sélectionnez « Redirect requests to this destination » puis entrez l’URL complète vers le répertoire virtuel de votre OWA
  • Sélectionnez « Only redirect requests to content in this directory ….. »
  • Cliquez ensuite sur « Apply »


Les modifications faites ci-dessus vont être appliquées aux répertoires virtuels inférieurs, naviguer dans les répertoires suivants et décocher cette option ci-dessus :

* aspnet_client

* Autodiscover

* ecp

* EWS

* Microsoft-Server-ActiveSync

* OAB

* OWA

* PowerShell

* Rpc


Cliquez sur « Apply » afin d’appliquer les modifications.

Décocher l’option « Require SSL » dans les propriétés du « Default Web Site »


Si besoin recochez l’option « Require SSL » dans la configuration des répertoires virtuels

Redémarrez ensuite IIS et votre configuration est terminée !


Attention je vous conseille vivement la lecture de cet article pour placer correctement les droits concernant l’OAB afin de ne pas rencontrer de problèmes lors du téléchargement de l’OAB pour les clients Outlook Anywhere.

Vous devez en effet ajouter les droits read et Execute pour « Authenticated Users » sur le fichier Web.config dans le répertoire OAB


Bonne lecture

David Pekmez

Posted in Owa-2010 | 1 Comment »

Comparaison des fonctionnalités entre OWA 2010 et Outlook 2010

Posted by David PEKMEZ le novembre 13, 2010


Je vous recommande vivement la lecture de ce post si la comparaison des fonctionnalités entre OWA 2010 et Outlook 2010 vous intéresse ! Comparaison de Steve Goodman sur son site à l’adresse suivante

http://www.stevieg.org/2010/11/comparison-outlook-2010-owa-2010-outlook-2011-features/

Je vous recommande chaudement la lecture quotidienne de ce site au passage

Bonne lecture !

David


 

Posted in Exchange 2010 Service Pack 1, Owa-2010 | Leave a Comment »

Exchange 2010 : Redirection automatique http vers https://…/owa

Posted by Teruin laurent le septembre 27, 2010


Nous avons tous eu le besoin de faire de la redirection d’URL avec les versions précédentes de Microsoft Exchange. Le but du jeu est de faire en sorte que lorsque vos chers utilisateurs tapent http://webmail.votrenomdesociete.com une redirection se fasse vers https://webmail.votrenomdesociete.com/owa. Pour ce faire, vous en conviendrez, il faut impérativement que votre serveur ou que votre reverse proxy écoute sur le port 80. Sinon point de salut. Dans le cas d’un serveur ISA vous pouvez très facilement faire une redirection des flux http vers Https. Celle-ci se faisant dans la règle de publication. Ce qui n’empêche pas d’ailleurs que votre ISA ou TMG doit écouter sur le 80 en tcp. Si vous essayez les anciennes méthodes celles-ci ne fonctionneront pas. Voici comment il faut procéder :

Pour que cela fonctionne il faut utilisez les fonctions de redirection de IIS et supprimer l’obligation d’utiliser la couches SSL.

Etape 1 : Mise en place de redirection vers Https://……/owa

Positionnez-vous sir le site web par défaut et éditer les redirections HTTP


Le souci de cette configuration c’est qu’elle va s’appliquer sur tous les répertoires situés en dessous. Si si ;-)) c’est vrai et par conséquent il faudra supprimer cette redirection sur l’ensemble des répertoires virtuels situés en dessous.

Etape 2 : Suppression de la redirection pour les sous répertoires virtuels

Vous m’excuserez mais je n’ai pas pris de screenshot pour tous les répertoires virtuels ;-)))

Etape 3 : Suppression de l’obligation d’utiliser SSL
Pour supprimer L’obligation d’utiliser SSL procédez comme le montre la figure suivante :


Vous pensez comme moi ? Vous avez raison ! Cette modification va s’appliquer sur tous les répertoires en dessous. Ce qui en soit… n’est pas correct. Alors .. c’est reparti.
Il faut repositionner le SSL sur les répertoires Exchange suivants : Aspnet_client, Autodiscover, Ecp, EWS, Microsoft-ActiveSync,OAB,Windows Powershell et RPC.
Une fois effectué ouvrez une commande cmd et exécutez un iisreset.
Lancer un navigateur et tapez votre commande http://Webmail.nomdevotresociete.com vous devriez être redirigé vers https://webmail.nomdevotre societe.com/owa

Cordialement
Laurent Teruin
Testé sur Exchange 2010 SP1 Uk version / Windows 2008 R2 Ent Uk X64

Posted in 1-EXCHANGE 2010, Cas-2010, Owa-2010 | 1 Comment »

Exchange 2010 : Impossible d’afficher les options dans OWA

Posted by Yohan Boullier le juillet 20, 2010


Description du problème :

Certains utilisateurs n’arrivent pas à accéder aux "options" dans OWA. Quand les utilisateurs cliquent sur le bouton "options", rien ne se passe. La fenêtre des options ne s’affiche pas et l’écran reste sur la boite de réception.

Cause du problème :

C’est un bug d’Exchange 2010 qui apparait si le paramètre "DefaultClientLanguage" du répertoire virtuel "\owa"" est configuré.

En effet par défaut ce dernier possède une valeur de "0". Dans ce cas de figure, lors de sa première connexion, un utilisateur sera prié de sélectionner une langue, le Francais par exemple.

Si le paramètre DefaultClientLanguage a une valeur autre que "0", il spécifie la langue de Microsoft Outlook Web App employée lorsqu’un utilisateur qui n’a pas sélectionné de langue dans la page Options se connecte à Outlook Web App.

TECHNET – Set-OwaVirtualDirectory
TECHNET – Configurer les paramètres de langue pour OWA

A partir du moment ou ce paramètre est différent de "0", toutes les boites aux lettres pour lesquelles les paramètres régionaux ne sont pas configurés (langue, fuseau horaire) ne pourront plus accéder à leur options dans OWA.

Résolution du problème :

Il faut effectuer l’une ou l’autre des actions suivantes :

- Reconfigurer le paramètre "DefaultClientLanguage" du répertoire virtuel "\owa" sur sa valeur par défaut, cad "0".

- Configurer les paramètres régionaux au niveau de la boite aux lettres.

Pour configurer les paramètres régionaux sur une boite aux lettres commencer par renseigner la langue :

Set-Mailbox  "John Doe" -Languages fr-FR

Puis le fuseau horaire :

Set-MailboxRegionalConfiguration -identity "John Doe" -TimeZone "Romance Standard Time"

On peut aussi configurer configurer les paramètres régionaux pour toutes les boites aux lettres pour lesquelles ce n’est pas fait avec le script suivant :

$listbal = get-mailbox
ForEach ($bal in $listbal)
{
$regionalconfig = get-MailboxRegionalConfiguration -identity $bal.identity

if (($bal.Languages -ne "fr-FR") -or ($bal.Languages -eq $null) -or (!$bal.Languages))
{
write-host "Configuration langue: " $bal.name
Set-Mailbox  $bal.identity -Languages fr-FR
}
if ($regionalconfig.TimeZone -eq $null)
{
write-host "Paramètres régionaux manquants: " $bal.name
Set-MailboxRegionalConfiguration -identity $bal.identity -TimeZone "Romance Standard Time" -Language "fr-FR" -confirm:$false
}
}

Note:
Le service pak 1 devrait corriger le probleme.

Posted in 1-EXCHANGE 2010, Owa-2010, Problémes 2010 | 2 Comments »

Comment recréer les anciens répertoires virtuels dans Exchange 2010

Posted by Teruin laurent le février 14, 2010


Traduit de l’anglais : article original : http://msexchangeteam.com/archive/2010/02/10/453991.aspx

L’installation de Microsoft Exchange 2010 du role CAS inclut l’installation des anciens répertoires virtuels Exchange. Les répertoires Public et Exchweb sont placés et configurés directement dans la metabase IIS, ainsi ces répertoires virtuels sont uniquement local et ne sont plus stocké dans l’environnement Active Directory. Parallèlement à cela la commande New-OWAVirtualDirectory ne comprend plus le paramètre -Name car le nom OWA est codé en dur dans cette dernière.

Ce comportement est différent de l’environnement Exchange 2007 ou il etait nécessaire de pouvoir recréer à travers la commande New-OWAVirtualDirectory les répertoires virtuels EXchange, Exchweb et Public. L’exécution de la commande Remove-OWAVirtualDirectory va alors supprimer les répertoires Exchange EXchWeb et Public incluant en plus le répertoire OWA. la commande New-OWAVirtualDirectory va alors recréer les répertoires virtuel anciens et le répertoire OWA.

Le problème resolu dans cet article comprend donc la recréation des répertoires virtuels anciens sans la destruction du répertoire OWA. Pour ce faire, vous devez utiliser l’utilitaire APPCMD ou ajouter les répertoires virtuels manuellement dans IIS et modifier le fichier applicaitonsHost.config.

Option 1 : Utilisation de APPCMD
Dans le but de recréer les anciens répertoires virtuels exécuter les tâches suivantes :

1- Ouvrez une ligne de commande et placer vous dans le répertoire %SystemRoot%\System32\inetsrv
2- Exécuter les commandes suivant en prenant soin de remplacer le parametre VDIR par le nom correct de votre répertoire virtuel ancienne génération 

  • appcmd delete vdir /vdir.name:"Default Web Site/<VDir>" /commit:APPHOST
  • appcmd add vdir /app.name:"Default Web Site"/ /path:/<VDir> /physicalPath:"<Exchange Install Directory>\V14\ClientAccess\Owa" /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:directoryBrowse /enabled:false /showFlags:"Date, Size, Extension, LongDate" /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:handlers /accessPolicy:Read /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:windowsAuthentication /enabled:false /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:anonymousAuthentication /enabled:true /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:digestAuthentication /enabled:false /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:basicAuthentication /enabled:false /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:defaultDocument /enabled:true /commit:APPHOST
  • appcmd set config "Default Web Site/<VDir>" /section:httpRedirect /enabled:true /destination:/owa /exactDestination:false /childOnly:false /httpResponseStatus:Found /commit:APPHOST

Le plus simple est de copier trois fois ce code et remplacer a chaque instance  

OPtion 2 : Modification du fichier applicationhost.config

Ouvrez le gestionnaire IIS ouvrer le site par défaut cliquez droit sur le répertoire VDIR et sélectionner Remove Sélectionner le répertoire par défaut et choisissez visualiser les répertoires virtuel dans le volet actions .Dans le panneau action choisissez ajouter un répertoire virtuel et ajouter le répertoire virtuel (Exchweb, Exchange ..) ainsi que le chemin correct "<Exchange Install Directory>\V14\ClientAcess\Owa" et cliquez sur OK
Par défaut le répertoire nouvellement créé va être positionné en Anonnyme par défaut. si cela n’est pas le cas il vous faudra modifier le fichier applicationHost.config en dessous afin de repositionner une authentification correcte.
Placer vous alors dans le répertoire %SystemRoot%\System32\Inetsrv\config\ et ouvrer le fichier applicationhost.config
Recherchez la chaine de caractère Default Web Site/owa/14" une fois trouvée, localisez le texte /Location après l’entrée </location>, Copiez et coller le texte suivant en prenant soin de modifier l’entrée VDIR par le nom du répertoire Virtuel à recréer.

<location path="Default Web Site/<VDir>">
      <system.webServer>
           <directoryBrowse enabled="false" showFlags="Date, Size, Extension, LongDate" />
           <handlers accessPolicy="Read" />
           <security>
                <authentication>
                    <windowsAuthentication enabled="false" />
                    <anonymousAuthentication enabled="true" />
                    <digestAuthentication enabled="false" />
                    <basicAuthentication enabled="false" />
                </authentication>
           </security>
           <defaultDocument enabled="true" />
           <httpRedirect enabled="true" destination="/owa" exactDestination="false" childOnly="false" httpResponseStatus="Found">
                <clear />
           </httpRedirect>
       </system.webServer>
   </location>

Une fois effectué, fermez le fichier applicationhost.config et envoyer en ligne de commande

IISRESET / Noforce

Laurent TERUIN

Posted in 1-EXCHANGE 2010, Owa-2010 | Leave a Comment »

 
Suivre

Recevez les nouvelles publications par mail.

Rejoignez 224 autres abonnés