Exchange your Mind

"La connaissance ne vaut que si elle est partagée" / "An effective Knowledge is a shared one"

Archive for the ‘Windows Server 2008 R2’ Category

Exchange : Correctif KB2550886 pour Windows 2008 R2 / R2SP1

Posted by Teruin laurent le novembre 23, 2011


KB2550886 – A transient communication failure causes a Windows Server 2008 R2 failover cluster to stop working

Le correctif proposé corrige des problèmes de de verrouillage de cluster en cas de problématique réseau. Il est vivement conseillé sur des infrastructures étendues sur deux sites distants. Dans le cas contraire le patch est malgré tout recommandé mais moins vital que pour les infrastructures réparties sur deux centres de données.

Dans le cas ou des perturbations réseaux sont rencontrées par Windows Failover cluster, la logique de reconnexion des nœuds du cluster engendrerai un blocage de la base de données du cluster ayant pour conséquence une perte des services de basculement.

Les équipes de Microsoft confirment avoir rencontré ces scénarios de blocage lors de perte de connexion réseau avoisinant les 60 Secondes. La résultante étant un blocage complet (deadLock) de l’intégralité du cluster avec pour conséquence un arrêt de toutes les bases de données.

Comme il n’est pas évident de déterminer quels nœuds du cluster sont effectivement bloqués (deadlockés) la seule solution est de redémarrer l’ensemble des membres du DAG afin de résoudre ce « verrou mortel ».

Le patch ainsi délivré permet de résoudre ce problème et comprend les correctifs suivants:

http://support.microsoft.com/kb/2549472 – Cluster node cannot rejoin the cluster after the node is restarted or removed from the cluster in Windows Server 2008 R2
http://support.microsoft.com/kb/2549448 – Cluster service still uses the default time-out value after you configure the regroup time-out setting in Windows Server 2008 R2
http://support.microsoft.com/kb/2552040 – A Windows Server 2008 R2 failover cluster loses quorum when an asymmetric communication fail

Il est à noter que ce correctif concerne également les clusters répartis en environnement Exchange 2007 reposant sur les technologies SCC et CCR. Par contre ne sont concerné que ceux fonctionnant dans l’environnement Windows 2008 R2 ou Windows 2008 R2 SP1.

A l’installation nous avons rencontré le problème suivant : Installer Encountered an error : 0X80070422


Ceci est dû au fait que les services BIT et Windows Update étaient arrêtés

Cordialement
Laurent Teruin

 

Posted in 1-EXCHANGE 2010, Cluster-2007, Cluster-2010, Exchange 2010 Service Pack 1, Windows Server 2008 R2 | Leave a Comment »

Exchange 2010 SP1 : ErrorR ’2147504141′ and message ‘This property can’t be found in the cache [Resolved] / it requires the object to have version 0.1 (8.0.535.0) or later. The object’s current version is 0.0 (6.5.6500.0).[Pending]

Posted by Teruin laurent le octobre 22, 2010


Today : 09 :15

 

Nous avons rencontré un souci d’installation sur un environnement installé from scratch en Windows 2008 R2 Standard Uk version X64 assurant le rôle de DC lors de la mise en place de Microsoft Exchange 2010 SP1 Uk Std
We have encountered an issue on a fresh Windows 2008 R2 Standard UK version X64 on Hyperv with DC role when installing Exchange 2010 SP1 UK Std version

L’erreur est la suivante :


 

[10/22/2010 07:41:05.0891] [2] Leaving ScSetupAtom
[10/22/2010 07:41:05.0938] [2] [ERROR] An error occurred with error code ’2147504141′ and message ‘This property can’t be found in the cache.’.
[10/22/2010 07:41:06.0221] [1] The following 1 error(s) occurred during task execution:
[10/22/2010 07:41:06.0221] [1] 0. ErrorRecord: An error occurred with error code ’2147504141′ and message ‘This property can’t be found in the cache.’.
[10/22/2010 07:41:06.0221] [1] 0. ErrorRecord: Microsoft.Exchange.Management.Deployment.ExsetdataException: An error occurred with error code ’2147504141′ and message ‘This property can’t be found in the cache.’.
[10/22/2010 07:41:06.0237] [1] [ERROR] The following error was generated when « $error.Clear(); install-ExsetdataAtom -AtomName SMTP -DomainController $RoleDomainController
 » was run: « An error occurred with error code ’2147504141′ and message ‘This property can’t be found in the cache.’. ».
[10/22/2010 07:41:06.0237] [1] [ERROR] An error occurred with error code ’2147504141′ and message ‘This property can’t be found in the cache.’.
[10/22/2010 07:41:06.0237] [1] [ERROR-REFERENCE] Id=LegacySMTPComponent___018cd23197294a33932d8458bdf7c28b Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
[10/22/2010 07:41:06.0237] [1] Setup is stopping now because of one or more critical errors.
[10/22/2010 07:41:06.0237] [1] Finished executing component tasks.
[10/22/2010 07:41:06.0379] [1] Ending processing Install-BridgeheadRole

 

The Ip configuration is this one:


 

Nous avons essayé de refaire l’installation après un reboot.
liens : http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/8f6ff508-2c09-4140-ba14-eca32bc5bf1d

We try to reboot the server and try again




[ERROR] The following error was generated when « $error.Clear(); set-ExchangeServerRole -Identity $RoleFqdnOrName -IsHubTransportServer:$true -DomainController $RoleDomainController »
was run: « Property IsHubTransportServer can’t be set on this object because it requires the object to have version 0.1 (8.0.535.0) or later. The object’s current version is 0.0 (6.5.6500.0). ».
[10/22/2010 08:13:05.0268] [1] [ERROR] Property IsHubTransportServer can’t be set on this object because it requires the object to have version 0.1 (8.0.535.0) or later. The object’s current version is 0.0 (6.5.6500.0).
[10/22/2010 08:13:05.0268] [1] [ERROR-REFERENCE] Id=BridgeheadRoleSetterComponent___ee2508bb29aa41be936a35daa983307a Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
[10/22/2010 08:13:05.0268] [1] Setup is stopping now because of one or more critical errors.

The current config is the following and we try again.


Same problem.


Après ca nous avons décidé de repartir d’une nouvelle installation
We decide to rebuild a fresh installation

 

Les commandes passées après une installation toute neuve de Windows 2008 R2 sont les suivantes. This are the commands after the fresh installation

netsh interface Ipv4 set address name= »Local Area Connection » source= »Static » address=192.168.1.99 mask=255.255.255.0 gateway=192.168.1.250 gw=1
netsh interface IPV4 set dnsserver « Local Area Connection » Static 192.168.1.99 primary

dcpromo /SafeModeAdminPassword:L07Bidas /RebootOnSuccess:Yes /DomainLevel:4 /ForestLevel:4 /RebootOnCompletion:Yes /NewDomainDNSName:CAIN.vessel /DomainNetBiosName:CAIN /ReplicaOrNewDomain:Domain /NewDomain:Forest /InstallDNS:Yes /Sitename=CAIN /unattend

Import-module servermanager
Add-WindowsFeature NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy,dhcp
shutdown /r /c « Restart After Exchange Pre-requisite »

Installation de tous les pre-requis
All requirement installation

And


We try to disable the UAC


And relaunch the setup




We decide to fix again a static IPV6 Address IP and try again


Same problem

We check for new update … in case of ..

We find this and decide to install these update and restart the computer


And … the winner is


We decide to change our Hyper-v setting machine


Redémarrage du serveur et ressaie
Restart the computer And try again ….

‘This property can’t be found in the cache [Resolved]

And …. New issue


Doit t’on vraiement complétement desinstaller IPV6
The question is should we really disable IPV6 ???

Alors on n’y vas . let’s go !


Et un petit reboot . And a restart .


La configuration est nettement plus simple / Our new IP configuration appear more simple !

Et on ressaye de nouveau  ! And try again ! and the winner is …


Pause dejeuner !!!! Lunch time !

 

If you click on « click here for hep »


 

Ok we decide to restart from a fresh installation… again ….

Before any installation

We fix a static IPV6 address and install .Net Framework and windows update again to update the .Net Framework 3.51SP1


Restart the computer

  • Changing the IPV4 address for a static on and DCpromo
  • dcpromo /SafeModeAdminPassword:L07Bidas /RebootOnSuccess:Yes /DomainLevel:4 /ForestLevel:4 /RebootOnCompletion:Yes /NewDomainDNSName:CAIN.vessel /DomainNetBiosName:CAIN /ReplicaOrNewDomain:Domain /NewDomain:Forest /InstallDNS:Yes /Sitename=CAIN /unattend
  • reboot
  • Install update Windows6.1-KB982867-v2-x64.msu (Win7) + reboot
  • Import-module servermanager
    Add-WindowsFeature RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy,dhcp
    shutdown /r /c « Restart After Exchange Pre-requisite »
  • Set-Service NetTcpPortSharing -StartupType Automatic

Ip configuration



Trying to install the Exchange 2010 SP1 .. and the winner is.


 

Well I forget to remove the time sync on hyper-v

So just do it restart the machine and retry and the winner is ..


 

6:15 PM Week end time…..

 


 

Posted in 1-EXCHANGE 2010, Exchange 2010 Service Pack 1, Installation-2010, Windows Server 2008 R2 | Leave a Comment »

 
Suivre

Recevez les nouvelles publications par mail.

Rejoignez 225 autres abonnés