Office Servers and Services

"La connaissance ne vaut que si elle est partagée" / "An effective Knowledge is a shared one"

Test-ActiveSyncConnectivity : FolderSync Failure

Posted by Teruin laurent sur avril 22, 2014


HI all

This morning my HLB don’t want to recognize that exchange ActiveSync Is up. To be sure I wanted to check with the Test cmdlet. By using this cmd let I ve got a Folder Sync Error.

Test-ActiveSyncConnectivity -ClientAccessServer srvexc01 -TrustAnySSLCertificate -MailboxCredential (Get-credential) –Verbose

VERBOSE: [15:48:37.599 GMT] Test-ActiveSyncConnectivity : Runspace context: Executing user:
company.loc/company/Users/Admin/ADM-xxx, Executing user organization: , Current organization: , RBAC-enabled:Enabled.
VERBOSE: [15:48:37.615 GMT] Test-ActiveSyncConnectivity : Active Directory session settings for ‘Test-ActiveSyncConnectivity’ are:
iew Entire Forest: ‘False’, Default Scope: ‘company.loc’, Configuration Domain
Controller: ‘SrvDC01.company.loc’, Preferred Global Catalog: ‘SrvDC02.company.loc’, Preferred Domain Controllers: ‘{SrvDC02.company.loc }’
VERBOSE: [15:48:37.615 GMT] Test-ActiveSyncConnectivity : Beginning processing Test-ActiveSyncConnectivity
VERBOSE: [15:48:37.615 GMT] Test-ActiveSyncConnectivity : Instantiating handler with index 0 for cmdlet extension agent « Admin Audit Log Agent ».
VERBOSE: [15:48:37.646 GMT] Test-ActiveSyncConnectivity : Current Scope Set is: { Recipient Read Scope: {{, }},Recipient Write Scopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient Scope(s): {}, Exclusive Configuration Scope(s): {} }
VERBOSE: The TrustAnySSLCertificate flag has been set. The task won’t verify that the server certificate is valid before sending the user requests and credentials to this server. User credentials will be used for the following user: company\adm-xxx.
Do you want to test Exchange ActiveSync connectivity on Client Access server SRVEXC01.company.loc?
VERBOSE: [15:48:37.739 GMT] Test-ActiveSyncConnectivity : Resolved current organization: .
CasServer LocalSite Scenario Result Latency(MS) Error
——— ——— ——– —— ———– —–
srvexc01 FR-Mysite Options Success &Log=PrxFrom:10.100.2…
srvexc01 FR-Mysite FolderSync Failure [System.Net.WebExcept…
VERBOSE: [15:48:38.176 GMT] Test-ActiveSyncConnectivity : Admin Audit Log: Entered Handler:OnComplete.
VERBOSE: [15:48:38.176 GMT] Test-ActiveSyncConnectivity : Ending processing Test-ActiveSyncConnectivity

I try from outside with a fresh created account quiet the same issue

Additional Details

 

HTTP Response Headers:
Allow: OPTIONS,POST
request-id: beaef73b-b57b-431e-85bd-0b84645fd576
X-CalculatedBETarget: srvexc01.mrsaero.loc
MS-Server-ActiveSync: 15.0
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Public: OPTIONS,POST
X-MS-BackOffDuration: L/-230
X-DiagInfo: SRVEXC01
X-BEServer: SRVEXC01
X-FEServer: SRVEXC02
Content-Length: 0
Cache-Control: private
Content-Type: application/vnd.ms-sync.wbxml
Date: Tue, 22 Apr 2014 12:44:05 GMT
Set-Cookie: X-BackEndCookie=S-1-5-21-2772383364-1376662479-776174872
202=u56Lnp2ejJqBnZzNzZ7Lmp7Smp2cy9LLz8aZ0p3Gnp7SysvIy53Gz8fKmsjNgYHPytDNzdDNz87L387NxcvLxc/K; expires=Thu, 22-May-2014 10:44:05 GMT; path=/Microsoft-Server-ActiveSync; secure; HttpOnly
Server: Microsoft-IIS/8.0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Elapsed Time: 560 ms.

Attempting the FolderSync command on the Exchange ActiveSync session.
The test of the FolderSync command failed.
    Additional Details
    Exception details:
Message: The operation has timed out
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.Tools.ExRca.Extensions.RcaHttpRequest.GetResponse()
Elapsed Time: 100037 ms.

Let see what result we have with the same new account internally. Hum…. very weird it is working internally which fundamentally is good😉

[PS] C:\Windows\system32>Test-ActiveSyncConnectivity -ClientAccessServer srvexc01 -TrustAnySSLCertificate -MailboxCredential (Get-credential) –Verbose
cmdlet Get-Credential at command pipeline position 1
Supply values for the following parameters: Credential
VERBOSE: [12:51:43.495 GMT] Test-ActiveSyncConnectivity : Runspace context: Executing user: company.loc/company/Users/Admin/ADM-Teruin, Executing user organization: , Current organization: , RBAC-enabled:
Enabled.VERBOSE: [12:51:43.495 GMT] Test-ActiveSyncConnectivity : Initializing Active Directory server settings for the remote
Windows PowerShell session.
VERBOSE: [12:51:43.510 GMT] Test-ActiveSyncConnectivity : Active Directory session settings for ‘Test-ActiveSyncConnectivity’ are: View Entire Forest: ‘False’, Default Scope: ‘company.loc’, Configuration DomainController: ‘SrvDC01.company.loc’, Preferred Global Catalog: ‘SrvDC02.company.loc’, Preferred Domain Controllers: ‘{SrvDC02.company.loc }’
VERBOSE: [12:51:43.510 GMT] Test-ActiveSyncConnectivity : Beginning processing Test-ActiveSyncConnectivity
VERBOSE: [12:51:43.542 GMT] Test-ActiveSyncConnectivity : Instantiating handler with index 0 for cmdlet extension agent « Admin Audit Log Agent ».
VERBOSE: [12:51:44.587 GMT] Test-ActiveSyncConnectivity : Current ScopeSet is: { Recipient Read Scope: {{, }}, Recipient Write Scopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient Scope(s): {}, Exclusive Configuration Scope(s): {} }
VERBOSE: The TrustAnySSLCertificate flag has been set. The task won’t verify that the server certificate is validbefore sending the user requests and credentials to this server. User credentials will be used for the following user: company\cader Do you want to test Exchange ActiveSync connectivity on Client Access server SRVEXC01.company.loc?
VERBOSE: [12:51:44.743 GMT] Test-ActiveSyncConnectivity : Resolved current organization: .

CasServer LocalSite Scenario Result Latency(MS) Error
——— ——— ——– —— ———– —–
srvexc01 FR-Site Options Success &Log=PrxFrom:fe80%3a%…
srvexc01 FR-Site FolderSync Success &Log=PrxFrom:fe80%3a%…
srvexc01 FR-Site First Sync Success &Log=PrxFrom:fe80%3a%…
srvexc01 FR-Site GetItemEstimate Success &Log=PrxFrom:fe80%3a%…
srvexc01 FR-Site Sync Data Success &Log=PrxFrom:fe80%3a%…
srvexc01 FR-Site Ping Success &Log=PrxFrom:fe80%3a%…
srvexc01 FR-Site Sync Test Item Success &Log=PrxFrom:fe80%3a%…
VERBOSE: [12:52:01.996 GMT] Test-ActiveSyncConnectivity : Admin Audit Log: Entered Handler:OnComplete.
VERBOSE: [12:52:02.012 GMT] Test-ActiveSyncConnectivity : Ending processing Test-ActiveSyncConnectivity

 

By using the https://testconnectivity.microsoft.com I ve got an issue but with my Android S4 from outside it works well. So … I don’t remember is https://testconnectivity.microsoft.com is ready for Exchange 2013 SP1. Not sure?
The first account who generate an error was domain Admin.

 

 

 

 

Laisser un commentaire

Choisissez une méthode de connexion pour poster votre commentaire:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

 
%d blogueurs aiment cette page :