0365 : Remove-InformationBarrierPolicy Failed [Solved]


Aujourd’hui je suis en train d’essayer de contourner le problème posé par les utilisateurs qui possèdent des licences EMSE5 et qui apparaissent comme des utilisateurs Fantômes de Teams. Pour ce faire le support Microsoft m’a orienté vers les fonctions d’information barrier. J’ai donc créé deux segments et une policy que je voudrai néanmoins supprimer. Seulement cela semble un peu plus compliqué que cela en à l’air.
Avant de supprimer un segment il faut s’assurer que ce dernier ne soit pas utilisé dans une policy. Je me suis donc attelé à la suppression de la Policy. Mais pour supprimer une Policy, il faut qu’elle soit inactive. J’ai donc positionné cette dernière dans ce mode comme en témoigne la copie d’écran ci-dessous

Today I am trying to get around the problem of users with EMSE5 licenses appearing as Teams ghost users. To do this, Microsoft support directed me to the barrier information functions. So I created two segments and a policy that I want to delete. But it seems a bit more complicated than it looks. Before deleting a segment, we have to make sure that it is not used in a policy. So I started to delete the policy. But to delete a policy, it has to be inactive. So I set it in the mode as shown in the screenshot below

Or lorsque je tente de la supprimer je rencontre ce message d’erreur / But when I try to delete it I get this error message

This address book policy « 5f217190-4a97-449a-a875-136069d7e4d4 » can’t be removed because it is being used by users. Before you can remove this address book policy, make sure that no users are linked to it

Je me suis donc dit que les segments attachés à cette stratégie devaient adresser des utilisateurs dans mon tenant. J’ai donc changé la nature du segment pour être sûr que les segments en question n’adressent aucun utilisateur présent dans le tenant.

So I thought that the segments attached to this strategy should address users in my tenant. So I changed the nature of the segment to make sure that the segments in question do not address any user present in the tenant.


Avec cette configuration les segments n’adressent aucun utilisateur et cependant je ne peux toujours par supprimer cette Policy. Dans l’onglet Policy Application j’aia remarqué que la Policy n’était pas démarrée. J’ai donc tenté de le faire, meme si celle-ci était inactive. Je rappelle que le tenant que j’opére contient 5 utilisateurs le traitement devrait ^étre par conséquent rapide.

With this configuration the segments do not address any user and yet I still cannot delete this policy. In the Policy Application tab I noticed that the policy was not started. So I tried to do it even if it was inactive. I recall that the tenant I’m operating on contains 5 Users so the processing should be fast.

Aprés 10 minutes j’ai pu constater que la policy (la seule présente dans le tenant) semblait s’etre correctement appliquée meme si celle-ci est marqué inactive./ After 10 minutes I could see that the policy (the only one present in the holder) seemed to be correctly applied even if it is marked inactive.

J’ai donc essayé de la supprimer de nouveau et la cela fonctionne  / So I tried to delete it again and it works

1 commentaire

Votre commentaire

Choisissez une méthode de connexion pour poster votre commentaire:

Logo WordPress.com

Vous commentez à l’aide de votre compte WordPress.com. Déconnexion /  Changer )

Image Twitter

Vous commentez à l’aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l’aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s